How can I change my profile picture?

Skip to the bottom

  • @karan  Jan 2019

    I've tried to change my profile pic, but it doesn't work! The website tells me I selected no file, although I did. The picture is small enough, and it's a jpg. Any advice?

  • @ericdistad  Jan 2019

    It sounds like you are getting an error when it tried to change? How big is the image and/or the file and what is the file name?

  • @yam655 Jan 2019

    When I tried to change my image earlier, it worked, but gave zero feedback that it worked. It looked like it failed. I was still presented with the same UI for changing my user profile. Since it clears the file field, if you try to press the button again, (thinking it did nothing), there's no file selected and you get that error.

    The browser also held on to the cached user-photo really hard. You basically need to flush the cache for the new photo to be seen. Logging out and back in doesn't refresh it. Closing the browser and reopening it doesn't flush it.

    @karan Is your new user profile picture a photo of you facing the left, holding a guitar, with a background that's like a darker version of the FAWM orange?

  • @johnstaples  Jan 2019

    @karan here is what I am seeing for your profile pic,

  • @karan  Jan 2019

    @ericdistad, the picture is definitely smaller than 500 kb.
    @yam655, yes, that's the one! So maybe it has changed after all? How do I flush the cache on my mobile, though ... *goes off to investigate* 😀

  • @karan  Jan 2019

    @johnstaples, with my normal browser it showed the old pic. I just changed browsers and, hooray, there's the new one!

  • @johnstaples  Jan 2019

    Nice pic, @karan !

  • @inkflow Jan 2019

    I'm in the same boat with the profile pic thing. For some reason it upload a file I didn't select, but when I try to use the image I want, the entire site fails and I get a white error screen :

  • @seemanski  Jan 27

    I am also getting the dreaded internal server error aka 500 whenever I try and change my piccie. @burrsettles, @ericdistad

  • @seemanski  Jan 27

    This was on my mobile, I'll try on a desktop and see if it works. Although it looks like something server side is going wrong to me.

  • @seemanski  Jan 27

    Looking the dev tools, there is a failing bit of javascript

    Uncaught ReferenceError: $ is not defined
    at (index):150
    (anonymous) @ (index):150

    Which is highlighting this:

    <script>
    $('.navbar-avatar img').attr('src', $('.navbar-avatar img').attr('src')+'?'+Math.floor(Math.random()*3000));
    </script>

    It is also throwing out a HTTPS errors.

    Mixed Content: The page at 'https://fawm.org/myfawm/art/' was loaded over HTTPS, but requested an insecure stylesheet 'http://fonts.googleapis.com/css?famil...'. This request has been blocked; the content must be served over HTTPS.

    Not sure if it is related but thought I would share it with you just in case.

  • @seemanski  Jan 27

    oh I see, the https errors are for google fonts that are hosted over http. That won't be the problem then.

  • @fourzeroes  Jan 27

    I updated mine but am still seeing the old one on mobile. What's anyone else seeing - traffic cone or sketched guitarist?

  • @seemanski  Jan 27

    Yeah, it crashes on mobile but just doesn't do anything when you change on desktop but throws out those javascript errors. It appears to post a message to the server when I monitor my network traffic but my pic stays the same. I'll leave it in the capable hands of the fawm techs now. Need anything to help recreate or retest, let me know. I bet you can't guess what my day job is 😋.

  • @toms  Jan 27

    @fourzeroes sketched guitarist.

  • @fourzeroes  Jan 27

    Cleared my Chrome cache from the Android apps menu instead of from within Chrome menus and it fixed it.

    @toms thanks, me too now 😀

  • @seemanski  Jan 27

    Still getting 500 errors on uploading via mobile but you are right about the browser cache @fourzeroes. I have changed my pic using desktop 😁

  • @fourzeroes  Jan 27

    @seemanski I changed mine successfully on mobile but it didn't show!

  • @darkmantle  Jan 27

    You need to clear your cache after changing it. This site has the steps for how to do that on all common browsers for all devices.

    https://kb.iu.edu/d/ahic

  • @seemanski  Jan 27

    Well I have got my pic changed now at least but I definitely was getting redirected due to an internal server error on android.

Leave a Message. Log in to FAWM or sign up first...