Tips for getting your MP3 demos to play properly

Skip to the bottom

  • @burrsettles  Feb 1

    Hi all โ€”

    If you're using soundcloud/youtube/vimeo you should be fine.

    However, if you're using direct links to MP3 files to share demos, here are some common troubleshooting tips:

    1. Make sure there are no spaces in the filename. In general, stick with basic letters, numbers, and "-" or "_" characters. (Technically, you can replace spaces with "%20" when you paste them in the FAWM demo field, but it's simpler to just avoid them altogether).

    2. If you're rolling your own hosting, make sure the URL starts with "https" (note the "s"), otherwise some browsers will block it. Since FAWM is served via https ("HyperText Trasfer Protocol, Secure"), if the player tries to stream something NOT over https it's considered a security threat. The fawmstar hosting we provide for $25+ donors should serve over https.

    3. If you use Dropbox to serve your demos, be sure to delete "?dl=0" from the end of the URL, and change the server address part from "" to ""

  • @ajna1960  Feb 1

    @rustyp this is what you are looking for. The fourth paragraph refers to Dropbox.

  • @rustyp Feb 1

    Yes, I did. ๐Ÿ˜ž

  • @vomvorton  Feb 1

    Ugh I didn't realise the https thing could be an issue.

  • @ajna1960  Feb 1

    @rustyp oh dear. Maybe send me the mp3 and I'll try and upload it ?

  • @burrsettles  Feb 1

    @rustyp your problem isn't the "?dl=0" bit, it's bullet 1: you have spaces in your filename. if you rename & re-upload without the spaces it should work.

  • @rustyp Feb 1

    Does this link look ok?
    I tried but I still can't get it to play in my browser. ๐Ÿ˜ž
    thanks for the help @burrsettles ย  .

  • @kathym  Feb 1

    I had to remember how to do this correctly using the fawm file hosting. I figured out that if I upload a song, then go to play it, I can copy the URL right where the song is playing and it saved me a bit of frustration.
    Now, if I can figure out how to get a better recording on my laptop using the Audacity program that I downloaded. I'm not sure if it's the program and I don't have the settings correct or what the problem is.
    My laptop has a built in mic and there's nowhere to plug in an auxiliary mic that I could find. There's a reason I play acoustic ...

  • @jendistad  Feb 1

    This forum thread is all about making dropbox play nice on FAWM.

  • @seemanski  Feb 5

    @burrsettles, in response to point 2. I am using the fawm hosting and I copy the https link when I upload my tracks but when I inspect the dom it is showing it as a http link and chrome is reporting the site as being insecure. I double checked this by re-uploading my fawm hosting link, making sure it was https, and it did the same thing.

  • @ericdistad  Feb 5

    @seemanski If you edit the song, wipe out the demo field, save the song, then re-edit and add the link with https:// at the front and save again, does it keep the https?

  • @ericdistad  Feb 5

    Actually @seemanski , scratch that. I think it did the same thing to me.

  • @andygetch  Feb 5

    when using the FAWM and 50/90 file hosting, I have found that if I use an apostrophe in the file name
    ' Can't Write A Song '
    will not play.
    ' Cant Write A Song'

  • @unpronounceable Feb 6

    Some folks are telling me my songs won't play. Some are getting it to play. I switched to https. I dunno what else to do.

  • @andreasb Feb 7

    I have a song that I linked to my Google drive yesterday. It works fine, but it takes me to that page to play it. So today I created a bandcamp and uploaded my track, and published it. But when I put my url in the track field, instead of providing an in-FAWM player, it's still directing me to the other page -- the bandcamp url now, but it's not providing the player in the FAWM interface. What am I doing wrong?

  • @winchperry Feb 7

    I am trying to upload my first demo to my FAWM profile and it's on soundcloud. When I paste the sharing link into the Fawm field I get an error saying I am not posting the proper soundcloud link, but I am copying it right from soundcloud and using the URL they say is the one for sharing. Any ideas, anyone? @burrsettles

  • @ericdistad  Feb 8

    @andreasb - In order to get the FAWM player to work the file has to be directly accessible to the FAWM players as an mp3. I.E.

    Unfortunately, neither Google Drive or Bandcamp makes the mp3 file directly accessible - they redirect to their own internal viewers/players.

    There are free options with Dropbox or Soundcloud, For Dropbox info, you can check out this forum thread:

    @winchperry - When I follow the link you pasted into your song notes, it tells me the track is not available? Did you make the track public? I don't know Soundcloud as well, but I think you have to make the track shared publicly for FAWM to be able to read it.

  • @burrsettles  Feb 8

    hi @winchperry โ€” it looks like that soundcloud URL isn't valid. when i go the the page over on soundcloud I get a "This track was not found. Maybe it has been removed" message, so the problem is not with the FAWM site or how it is embedding soundcloud tracks....

  • @dreamscuba  Feb 8

    Hi @burrsettles , thank you so much. I was wondering why I and others had problems playing my songs from some devices....the https issue. As I didn't know the root cause of the issue, I moved my songs to SoundCloud. Luckily, my hosting plan comes with free SSL, so I have enabled this and my links work...I will move back to using my own site for the next song. Noted on file naming protocol. Thanks again!!

  • @mhorning Feb 8

    I am seeing a bunch of FAWM hosted songs that won't play in Firefox, but they do work in Chrome. No idea why. Externally hosted songs work fine.

  • @winchperry Feb 8

    @burrsettles Yes, the problem was that I had to make the soundcloud post Public and not Private. It's supposed to allow me to share a link even for private songs, but I guess that doesn't work for FAWM. Thank you @ericdistad for your suggestion!

  • @metalfoot  Feb 8

    @dreamscuba I have Ionos hosting and it was about a 30 second fix to set up the SSL certificate to fix the problem for me. ๐Ÿ˜€

    @mhorning do you still have flash installed on FF? Because that will mess with the player.

  • @dreamscuba  Feb 8

    @metalfoot thanks...yes...once I read this thread and understood the root cause, it was about 30 seconds to enable it (after I found out where in my control panel to do that...).

  • @mhorning Feb 8

    @metalfoot bingo. Even from beyond the grave Flash wreaks is vengeance upon us.

  • @unpronounceable Feb 13

    Iโ€™m curious what the shift is this year that is causing mp3 playing problems on the site. Iโ€™m having this weird issue where I canโ€™t play my own songs if itโ€™s not http. Iโ€™m not sure changing it to https is really helping.

  • @metalfoot  Feb 13

    @unpronounceable You might need to activate a SSL certificate on your website domain to make it https compatible. Depending on who your hosting company is, they may provide one for free (like mine did) and it's just a matter of installing it.
    The shift is Chrome/Edge as a browser determining that anything not https is unsafe on the internet and essentially forcing the browser to treat it as such.

  • @unpronounceable Feb 13

    @metalfoot Thank youuuuuuuuu, activated and trying this out...

Leave a Message. Log in to FAWM or sign up first...